Sumowanie wartości z błędami

W codziennej pracy często tworzone są raporty, w których pojawiają się błędy (np. #N/D!, #DZIEL/0!). Niejednokrotnie błędy te zostawia się specjalnie i nie można ich usunąć. W tym momencie pojawia się problem – funkcje wyliczające zamiast poprawnych wartości pokazują błędy, które wystąpiły wcześniej. Z tym problemem bardzo łatwo można sobie poradzić wykorzystując funkcje tablicowe.

Excel dysponuje funkcjonalnością, która pozwala przeprowadzać obliczenia na danych przechowywanych w postaci tablicy – formuły (funkcje) tablicowe. W przypadku ich użycia argumentami są tablice (maksymalnie dwu wymiarowe), zamiast pojedynczych wartości. Inny jest również sposób akceptacji takiej formuły – na zakończenie edycji należy wprowadzoną formułę zaakceptować naciskając Ctrl+Shift+Enter.

Rozwiązanie tego problemu jest bardzo proste funkcja, która będzie np. sumowała wartości z danej kolumny powinna pomijać błędne wartości. Rozwiązanie wydaje się nie być trudne. Dla osób, które nie są zaznajomione z pracą z Excelem najprostszym rozwiązaniem jest stworzenie dodatkowej kolumny koło kolumny sumowanej, w której to będą przetrzymywane wartości prawidłowe. Osiągnąć to można za pomocą formuły:

=JEŻELI(CZY.BŁĄD(A1);””;A1)

Powyższa formuła w sytuacji gdy w komórce A1 pojawi się błąd zwraca wynik w postaci pustego ciągu znaków. W sytuacji gdy znajdzie się tam wartość poprawna – skopiuje tą wartość. Teraz wystarczy tylko już tylko stworzyć funkcję sumującą i jako argumenty formuły podać wartości zamiast z kolumny źródłowej to z obliczonej. Na koniec wystarczy tylko ukryć kolumnę z obliczonymi wartościami. Rozwiązanie to jest jednak bardzo nie elegancie i wymaga stworzenie dodatkowej niepotrzebnej kolumny.

Lepszym rozwiązaniem jest wykorzystanie funkcji tablicowych. Funkcja ta wykona dokładnie to samo co poprzednie rozwiązanie, ale nie będzie wymagała stworzenia dodatkowej kolumny. W tym celu należy połączyć wszystkie wykorzystane wcześniej funkcje:

{=SUMA(JEŻELI(CZY.BŁĄD(C2:C8);””;C2:C8))}

Należy pamiętać przy tym, że tak wprowadzoną funkcje należy zaakceptować poprzez naciśnięcie Shift+Ctrl+Enter.

Sumowanie z błędamiW przypadku gdy jest się użytkownikiem Excela 2007 można wykorzystać nową funkcję JEŻELI.BŁĄD. Spowoduje to uproszczenie powyższej formuły do następującej postaci:

{=SUMA(JEŻELI.BŁĄD(C2:C8;””))}

Takie rozwiązanie można użyć również w przypadku innych funkcji (np. MIN, MAX, ŚREDNIA), które są dość często używane do wyliczania wartości.

Opublikowano: 30 marca 2009, Kategorie: Formuły , , ,
Jedna odpowiedź na Sumowanie wartości z błędami
  1. avatar

    Pomogło, dziękuję :)

    Odpowiedz

[na górę]

Dodaj komentarz

Twój adres e-mail nie zostanie opublikowany. Pola, których wypełnienie jest wymagane, są oznaczone symbolem *

Możesz użyć następujących tagów oraz atrybutów HTML-a: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code class="" title="" data-url=""> <del datetime=""> <em> <i> <q cite=""> <s> <strike> <strong> <pre class="" title="" data-url=""> <span class="" title="" data-url="">