Wielotablicowe WYSZUKAJ.PIONOWO

Jednym, z problemów pojawiających się przy pracy z dużą ilością danych jest ograniczona ilość wierszy, które może przechować Excel. W przypadku Excela 2003 ilość wierszy możliwych do wykorzystania wynosi 65536. W przypadku wersji Excel 2007 ilość ta uległa zwiększeniu i wynosi 1048576. Dodatkowo czasami istnieje potrzeba rozdzielenia danych na kilka tabel. I tu pojawia się pytanie jak można użyć funkcji WYSZUKAJ.PIONOWO.

Rozwiązanie tego problemu jest bardzo proste. Należy użyć złożenia dwóch funkcji:

  • WYSZUKAJ.PIONOWO,
  • JEŻELI.

Funkcja JEŻELI będzie odpowiedzialna za wybór tablicy, z której mają zostać pobrane dane w zależności od ustalonego warunku:

=WYSZUKAJ.PIONOWO(Szukana wartość; JEŻELI(Warunek; Tablica 1; Tablica 2); Nr kolumny; Dopasowanie)

W poniższym przykładzie kluczem wyboru tablicy jest długość kodu. Tablica 1 (A3:B6) zawiera wszystkie produktu, których kod jest 3 literowy. Tablica 2 (A11:B14) – produkty dla kodów 4 literowych. W tym przykładzie użyto dodatkowo funkcji  do określania długości kodu.

Wielotablicowe Wyszukaj.PionowoNależy również zauważyć, że nic nie stoi na przeszkodzie, aby tablice z danymi znajdowały się w różnych arkuszach, jak również, aby ich ilość była większa niż dwa.

Opublikowano: 26 marca 2009, Kategorie: Formuły ,

Dodaj komentarz

Twój adres e-mail nie zostanie opublikowany. Pola, których wypełnienie jest wymagane, są oznaczone symbolem *

Możesz użyć następujących tagów oraz atrybutów HTML-a: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code class="" title="" data-url=""> <del datetime=""> <em> <i> <q cite=""> <s> <strike> <strong> <pre class="" title="" data-url=""> <span class="" title="" data-url="">